[PD] pix_video odyssey: no method on 2 systems

chris clepper cgc at humboldtblvd.com
Thu Mar 31 16:27:49 CEST 2005

pix_video on OSX will use the first video input device it finds.  
Object creation will dump some lines about the device and the object to 
the terminal/console - what does that say?  Does the device work with 
other Quicktime based capture applications?  Sometimes it helps to 
setup the device in one of those apps using the standard QT dialog 
before starting GEM.  Unfortunately, I have never found a way to make 
that same dialog work in GEM because of the way event loops in Carbon 
work.  There is a scandalously small amount of info about manipulating 
capture devices without using that dialog too.


On Mar 31, 2005, at 1:19 AM, Ian Smith-Heisters wrote:

> I've been trying to get pix_video working satisfactorily on a number 
> of systems, and have finally settled on using a G4 PowerBook. I've 
> never really used Mac OSX beyond some basic network and programming 
> stuff, so bear with me please.
> I downloaded the pd 0.38-3 app from 
> http://pcm.peabody.jhu.edu/~sburt/pd/installing_pd_os_x.html, it 
> loaded Gem 0.90 without error.
> When I send [open 0( [device 0( [driver 0( [enumerate( or any other 
> methods besides [dim( I get
> pix_videoDarwin: no method for 'open'
> ...or whatever method I tried. I found this problem in the archives in 
> 2003, but renaming pix_video to pix_videoDarwin, as suggested, didn't 
> help anything.
> I got the same error with Hans-Christoph Steiner's installer and a 
> manual installation from SF.net. I also got a similar error trying 
> DeMuDi 1.1.1 on another computer.
> What gives? Am I doing something just utterly stupid? Thanks for any 
> help you can offer.
> -Ian
> -- 
> http://www.0x09.com
> _______________________________________________
> PD-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> 
> http://iem.at/cgi-bin/mailman/listinfo/pd-list

More information about the Pd-list mailing list