[PD] help needed figuring out why pd on ubuntu hangs

Ivica Ico Bukvic ico at fuse.net
Fri Jun 3 03:00:41 CEST 2005

Hi all,

I just recently upgraded to Ubuntu and even though the distro comes with
pd debs included when I install the package or even if I try to compile
from source the following happens regardless of what flags I pass to pd:

ico at 64bit-ubuntu:~/Desktop/pd-0.38-4-devel-1$ pd -verbose
Pd version 0.38.4 devel
compiled 20:48:09 Jun  2 2005
port 5400
"/usr/local/lib/pd/bin/pd-gui" 5400
Waiting for connection request...

Obviously, if I don't use "verbose" flag I don't get the printout below
the call, but whichever way I try to spawn the application (including
various flag combinations), the end result is the same: the pd at this
point simply waits (hangs) as if there is no connection to be made.

Ctrl+c at this point gives me:

Pd: signal 2

I tried prepackaged deb for ubuntu, as well as 0.37.1 extended and
0.38.4 devel non-extended versions from source and they all behave in
the same fashion.

What is interesting is that there are no /usr/local/lib/pd/tcl/library
and /usr/local/lib/pd/tk/library folders, but even when I tried
sym-linking them to appropriate lib folders, that still failed.
Furthermore, from looking into other people's posts, apparently on their
machines this worked as I saw, according to their included logs, that
their versions of pd also looked into these folders.

To make the matters worse, I am in a quite bit of a time bind and
therefore I would greatly appreciate any help I can get in this matter.

Thank you very much!

Best wishes,


More information about the Pd-list mailing list