[PD] installing readanysf~ flext not found

Gerda Strobl bach at sbox.tugraz.at
Wed Aug 3 14:21:55 CEST 2005

Hi Georg!

I added tmy path in the src/Makefile--still the same error:
/usr/bin/ld: cannot find -lflext
collect2: ld returned 1 exit status
make[2]: *** [readanysf~.pd_linux] Error 1
make[2]: Leaving directory `/home/gerda/download/readanysf~0.13.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/gerda/download/readanysf~0.13.1'
make: *** [all] Error 2

I tried to configure using ./configure and also ./configure 
--with-flext-dir=/usr/local/lib/pd/flext/   always the same error.

You changed anything else?

> Hallo Gerda!
> Anyway, you have to add the path, where the flext library is to the linker:
> in src/Makefile there is somewhere this line:
> LDFLAGS = -L/usr/local/lib -ldl -shared
> and there you have to add also your flext path:
> LDFLAGS = -L/usr/lib/pd/flext -L/usr/local/lib -ldl -shared
> maybe I will fix this in the next days ...
> LG
> Georg
> --
> GMX DSL = Maximale Leistung zum minimalen Preis!
> 2000 MB nur 2,99, Flatrate ab 4,99 Euro/Monat: http://www.gmx.net/de/go/dsl


More information about the Pd-list mailing list