Fwd: [PD] GEM failure glDeleteProgramsNV

zmoelnig at iem.at zmoelnig at iem.at
Fri Sep 30 09:37:32 CEST 2005

Zitiere Christian Veit <fanfare at gmx.at>:

> Hallo,
> > > Can anyone give me a hint? (i'am new to linux,pd and gem)
> > ./configure --disable-openGL
> > (if you don't need the openGL wrappers, as usual ...)
> > 
> ok, i don't need the openGL wrappers that's right, i've tried it but
> there
> is the same error message undefined Symbol glDeleteProgramsNV. The

this is in the fragment/vertex-shader in the Manips-section (that is why
disabling openGL-wrappers doesn't help you)

> strange
> thing is that i have had compiled a running version of gem, but after
> a
> kernel change this message occured... The problem was that openGL was
> rendering on my CPU instead of my graphic card so a friend changed the
> kernel to 2.6.10-5-686, now openGL rendering on GPU is working...
> could
> there be a problem? When i had tried to compile Gem the first time (on
> the

the thing is, that mesa seems to not have glDeleteProgramsNV() (i have to check
if you are using an nvidia-card, be sure that you have installed there
implementation of glx in addition to the driver (on debian you have to install
nvidia-glx (and nvidia-glx-dev won't hurt too( in addition to nvidia-kernel-2.6.10)

this should make it running.

you could also try to configure with "--disable-ARB" (or was it
"--without-ARB"?), but i am not sure whether it helps here.

> old 2.6.10 kernel) i also got this error message but then i've installed
> the
> imagemagick library and then it worked...

in this case imagemagick will not help you at all (but it is no harm, and i
would advise anybody to have imagemagick++6-devel installed when building Gem)


More information about the Pd-list mailing list