still JACK trouble [was: [PD] [osx] pd++0.39-1Beta available]

james tittle tigital at
Wed Nov 2 00:03:30 CET 2005

On Nov 1, 2005, at 5:19 PM, derek holzer wrote:

> still no Jack support in this one? Funny thing is, even without  
> Jack running, and no -jack startup flag, I still get no sound and  
> the following:

...yup, no jack support in thar, but I'll see about adding it soon...

> unknown API
> audio I/O stuck... closing audio
> sys_close_audio: unknown API 5
> Nothing gets audio running as far as I can see. Let me know if you  
> need any particulars beyond the fact that I'm running 10.4.

...what kind of audio device are you using?  I've noticed that the  
audio settings don't necessarily stick between sessions, so have you  
tried turning on the audio output via the preferences/audio setup  
menu, after startup?

...I also should mention that there are real problems with 0.39-1 and  
shutting down:  it won't shutdown properly for me, but hangs and I  
have to ctrl-c out, which usually leaves a zombie pd process going  
(with midiserver), which I've found it's really necessary to kill  
that before launching again, because it's otherwise inviting trouble..., maybe tonight I'll be able to scrap together another app pkg  
with jack and 0.39-0 (which doesn't exhibit the above probs)...


More information about the Pd-list mailing list