[PD] pix_movie problem

Item State itemstatechanged at yahoo.de
Thu Feb 2 17:17:29 CET 2006


i'm new to PD and GEM. i'm trying to write a simply
movie player, starting off with the help patch of
pix_movie . it seems to work basically fine, but the
"texture" is only monochrome, like it would take just
one pixel of the movie and paint the whole geo with
that pixel's colour (i see the colour spinning as the
frames progress).

i'm on mac os x 10.3.9 / quicktime 7.0.4 and use the
latest build from h.c. steiner . when i open the
movie, the frame# and dimensions are reported
correctly . i also read that there was an issue with
power-of-two sizes of textures, so i tried to load a
256x256 movie as well, same problem. the patch is
attached. i also tried a different geo (cube instead
of rectangle), same behaviour.

some other questions :
- how do i determine the FPS value of the movie?
- can i display movies without the open GL context ; i
don't need open GL at all, i just need to render the
plane movie data, like i would connect a jit.qt.movie
to a jit.window object in jitter.
- can i switch to fullscreen mode?

thanks a lot! best, -sciss-

Do you Yahoo!? 
The New Yahoo! Movies: Check out the Latest Trailers, Premiere Photos and full Actor Database. 

More information about the Pd-list mailing list