[PD] some macro ideas

Frank Barknecht fbar at footils.org
Thu Oct 5 08:09:19 CEST 2006

Mathieu Bouchard hat gesagt: // Mathieu Bouchard wrote:

> >1) Subpatches - single fixed code blocks
> >2) Aliases - reusable code blocks within the main file
> >3) Abstractions - reusable code blocks in separate files
> I believe that (2) should still be called Abstractions, unless we get 
> another name for both (2) and (3) which is less vague and/or less long 
> than Abstractions.

It occured to me, that "1) Subpatches" already have a different name
which IMO is a much better name for the concept realized: "page".
Maybe I'll use [page whatever] from now on in my patches. It's a
better name because subpatches aren't patches themselves, but parts of
a patch much like objects. Like pages in a book, sub"pages" are used
to collect and organize content, that doesn't fit on one page alone.

(Embedded abstractions may be called subpatches then, but it's too
late for that.)

 Frank Barknecht                 _ ______footils.org_ __goto10.org__

More information about the Pd-list mailing list