[PD] some macro ideas
matju at artengine.ca
Thu Oct 5 20:38:33 CEST 2006
On Thu, 5 Oct 2006, Frank Barknecht wrote:
> It occured to me, that "1) Subpatches" already have a different name
> which IMO is a much better name for the concept realized: "page".
I would have used [page] instead of [pd], long ago; however, in 2002 or
2003, I found a bug that only applies to [page] and not [pd], and reported
it on pd-list, but it never got fixed. This is because subpatches need a
special hack in order to not lose their contents while being deleted. This
is because pd doesn't have the reinitialization feature of jMax, so
something had to be hardcoded, and it got hardcoded for [pd] but not for
[page]. This is a two-line fix that I could provide if you want it.
_ _ __ ___ _____ ________ _____________ _____________________ ...
| Mathieu Bouchard - tél:+1.514.383.3801 - http://artengine.ca/matju
| Freelance Digital Arts Engineer, Montréal QC Canada
More information about the Pd-list