[PD] GridFlow 0.8.4 on Mac OS 10.3.9

day 5 day5ive at gmail.com
Sat Oct 14 00:03:01 CEST 2006


i'm trying to peep out the new gridflow 0.8.4 and everything seems to  
compile correctly on OS X 10.3.9 with ruby-1.8.5 compiled with  
--enable-shared --enable-pthread (libruby.dylib)

gridflow spits out the following error on initialization

[LoadError] [no such file to load -- gridflow]:
(eval):1:in `require'

this is what gets printed in the Pd window

setting up Ruby-for-PureData...
gridflow.pd_darwin found itself in  
we are using Ruby version 1.8.5
DIR =  
Ruby's path =  
optional/rblti", "/usr/lib/ruby/site_ruby/1.8",  
"/usr/lib/ruby/site_ruby", "/usr/lib/ruby/1.8",  
"/usr/lib/ruby/1.8/powerpc-darwin7.9.0", "."]
ERROR: Cannot load GridFlow-for-Ruby (gridflow.so)

i tried everything - upon making gridflow i was left with  
gridflow.dylib and gridflow.pd_darwin and i tried doing ln -s  
gridflow.dylib gridflow.so and put it in all the pd directories and the  
directories in PATH but no joy

also, i think gridflow.so is a linux convention as i use gridflow on  
linux regularly is there someplace in the ruby sources to change the  
require statement to the correct extension?

an additional note is that i'm trying all this with the Hans  
Christoph-Steiner Pd.app distribution - is this even possible or does  
it only work if you build Pd from source?


More information about the Pd-list mailing list