[PD] set up edirol ua-25

Matthias Blau blau_m at web.de
Wed Jan 3 14:18:26 CET 2007

Hi list,

I finally solved the problem:
Upgrading to the newest versions of jack and pd in Debian Etch 
miraculously enabled me to start pd with jack.
Pd with alsa alone still doesn't work - any explanations?

Thanks, Matthias

Cesare Marilungo schrieb:
> Frank Barknecht wrote:
>> Hallo,
>> Matthias Blau hat gesagt: // Matthias Blau wrote:
>>>> If your pd has been compiled with --enable-alsa you should be able to
>>>> choose it from the menu Media->ALSA. Then do Startup->Save all 
>>>> settings.
>>> I can choose it from that menu but I get
>>> "snd_pcm_hw_params_set_format: Invalid argument"
>>> and
>>> "tried but couldn't sync A/D/A
>>> audio I/O stuck... closing audio"
>>> messages. I get the same errors on 2 different computers which run pd
>>> fine otherwise.
>>> I forgot to say that I use pd 0.39-1test1 and ALSA 1.0.13.
>>> The sampling rate switch on the UA-25 is at 44100 and so is the setting
>>> in pd's media-alsa menu.
>> Preferably you should use 48000 with USB soundcards (or any other
>> samplerate that is a multiple of 1000.)   
> In fact I've noticed that I can achieve much lower latency (64x2 
> samples) since when I switched to 48000 with my UA-25.
> But I didn't know that this setting was preferable.
> c.
>> Did you try the plughw:X devices in Pd's ALSA menu? And what about
>> using OSS or jack?
>> Ciao

More information about the Pd-list mailing list