[PD] general libdir question

Georg Holzmann grhPD at gmx.at
Mon Jan 29 20:21:59 CET 2007


>> Okay, but when I start pd -lib libdir and then make an [import 
>> iemmatrix] I get the message:
>>     libdir_loader: added iemmatrix to the canvas-local path
>>     [import] loaded library: iemmatrix
>> but I cannot use [mtx_add], only [iemmatrix/mtx_add]
> Yeah, same for me.  I don't have time to look at this right now.  I've 
> barely tried the Pd-0.40.2-extended builds, I expect they are very 
> rough.  Try turning on -verbose and seeing what it's trying to load.

I fixed it now, but I don't know if this is not a bug in pd 0.40:

The problem is, that canvas-local search path really tread each path as 
local to the canvas-path ( see line 1561 in g_canvas.c).
So if you add e.g. /usr/local/lib/pd/extra/iemmatrix, it will search for 
this path, but local to the canvas path - so if I started Pd from 
/home/me it will search in /home/me//usr/local/lib/pd/extra/iemmatrix !

Is this a feature or a bug of Pd ?

I fixed it now in libdir.c, so that I add 
../../usr/local/lib/pd/extra/iemmatrix to the canvas-local search path 
instead of /usr/local/lib/pd/extra/iemmatrix ...
But I cannot guarantee that this will also work on windows ...


More information about the Pd-list mailing list