[PD] [Gem]: [pix_texture] doesn't work

Roman Haefeli reduzierer at yahoo.de
Wed Feb 21 14:33:49 CET 2007

hello all

after not touching a working gem-compile for a few weeks now, i tried
Gem again for a course in my study. but it seems. it doesn't work
correctly anymore.
whenever i have a patch open with a [pix_texture] in the render-chain
and i try then to create the the gem-window ('create'->[gemwin]), the
window border appears, but the window-content is not redrawn (the
desktop from behing is still shown) and i see the following message in
the pd-window:
'fglrx: Failed to map back buffer!'
and i get this message when turning rendering on:
'GL: invalid enumerant'

my version of gem is:
GEM: ver: 0.91-cvs
GEM: compiled: Nov 30 2006

i am on ubuntu dapper with the fglrx-driver from the ubuntu-repository.
it worked in earlier days and i did not recompile gem since then. i
tried to recompile a checkout from today,  but when gem is loaded during
pd-startup, i get:

/usr/local/lib/pd/extra/Gem.pd_linux: /usr/local/lib/pd/extra/Gem.pd_linux: undefined symbol: glUniform2i

(can i avoid this by disabling a certain switch in ./configure?)

all other apps that i have installed and use opengl (armagetron,
blender, mplayer -vo gl) work without any problems and are able to show
textures. gem is the only app, that doesn't work as expected. but when
start X without dri enabled, [pix_texture] works. 

any help very appreciated.


Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de

More information about the Pd-list mailing list