[PD] [Gem]: [pix_texture] doesn't work

Roman Haefeli reduzierer at yahoo.de
Thu Feb 22 10:45:44 CET 2007

hi IOhannes

thank you for the fast reply. in the meantime i tried the binary from
Pd-0.39.2-extended-test7-ubuntu-dapper-i386 and: it worked well.

On Wed, 2007-02-21 at 16:42 +0100, IOhannes m zmoelnig wrote: 
> hi
> Roman Haefeli wrote:
> > 
> > my version of gem is:
> > GEM: ver: 0.91-cvs
> > GEM: compiled: Nov 30 2006
> so you have not changed Gem but you have updated your driver and now it
> doesn't work any more?

exactly, at least iirc, ubuntu's package manager once update some
> > i am on ubuntu dapper with the fglrx-driver from the ubuntu-repository.
> > it worked in earlier days and i did not recompile gem since then. i
> > tried to recompile a checkout from today,  but when gem is loaded during
> > pd-startup, i get:
> > 
> > /usr/local/lib/pd/extra/Gem.pd_linux: /usr/local/lib/pd/extra/Gem.pd_linux: undefined symbol: glUniform2i
> > 
> > (can i avoid this by disabling a certain switch in ./configure?)
> yes, finally there is!
> use "./configure --with-glversion=1.5"
> or - even better - get drivers that provide header-files which match.

hm... how can i make sure, that i have the correct headerfiles? as far
as i can tell i didn't install new headerfiles manually. the fact, that
the the binary from hcs' pd-extended works, makes me think, that the
problem is specific to my system (wrong headers?). what do i need to do
in order to make sure, that i the ./configure of gem looks at the
correct headers, respectively that i only have the correct headers

> > 
> > all other apps that i have installed and use opengl (armagetron,
> > blender, mplayer -vo gl) work without any problems and are able to show
> > textures. gem is the only app, that doesn't work as expected. but when
> > start X without dri enabled, [pix_texture] works. 
> does the rest of Gem work or is it just the textures?

with my own compile i didn't try everything, but i tried some of the
help-patches and i had troubles with [pix_texture] (resp. any file that
contains [pix_texture] like pid_image.pd, pix_video.pd and pix_film.pd
and the like) and with [model]. but i only tried an obj-file with around
5000 polygons, that worked on another ubuntu-ppc machine with the
gem-install from the distro.

> in any case, please file a bug-report at http://sf.net/projects/pd-gem

yes, thank you for the link. i'll do so, if things really look like not
me/my system being the problem but gem.


> mfa.dr
> IOhannes

Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de

More information about the Pd-list mailing list