[PD] [Gem]: [pix_texture] doesn't work

Roman Haefeli reduzierer at yahoo.de
Thu Feb 22 16:58:17 CET 2007

hi IOhannes

On Thu, 2007-02-22 at 11:13 +0100, IOhannes m zmoelnig wrote:
> Roman Haefeli wrote:
> > hi IOhannes
> > 
> > thank you for the fast reply. in the meantime i tried the binary from
> > Pd-0.39.2-extended-test7-ubuntu-dapper-i386 and: it worked well.
> which version of Gem is this?

GEM: ver: 0.91-cvs
GEM: compiled: Jan  5 2007

> >> use "./configure --with-glversion=1.5"
> >> or - even better - get drivers that provide header-files which match.
> > 
> > hm... how can i make sure, that i have the correct headerfiles? as far
> > as i can tell i didn't install new headerfiles manually. the fact, that
> > the the binary from hcs' pd-extended works, makes me think, that the
> > problem is specific to my system (wrong headers?). what do i need to do
> > in order to make sure, that i the ./configure of gem looks at the
> > correct headers, respectively that i only have the correct headers
> > installed?
> the problem is, that your packageing system installs headers which
> conform to openGL-2.0 but your driver (this is: the binary library) doesn't.
> this is a known issue with ati-drivers, but it appeared to happen with
> mesaGL too in recent versions.
> i am not sure whether this could be considered really a bug on the
> driver (header) side, but i tend to think so.
> i could of course create tests during the configure process that test
> for each and every openGL function used by Gem whether it is really
> supported by the driver. but this is like writing the headers yourself,
> and i don't see a reason to do that (why are headers provided?)
> i don't know of any other way to test these things at (configure or)
> compile time, therefore i leave it to the user to decide.
> (it is not that i haven't tried to find a generic way to check; but i
> haven't found any working solution, so i did the configure-flag; thanks
> to ico for the trigger)
> some my advice is:
> if you experience problems with unresolved openGL-symbols, try to lower
> the maximum openGL-version manually via the "--with-glversion" argument
> until Gem runs.

ok. i'll try that. many thanks for all that info.

> on the long run Gem will switch to glew (this has been around for years)
> which might fix these problems.

sounds good :-)
> > with my own compile i didn't try everything, but i tried some of the
> > help-patches and i had troubles with [pix_texture] (resp. any file that
> > contains [pix_texture] like pid_image.pd, pix_video.pd and pix_film.pd
> so this means, that trivia like the red-square example did work?

yes, i didn't test too much, but many things worked ok, e.g all geos and
'standard' objects like [translate{XYZ}], [color{RGB}].

i'll try to compile again. many thanks again for all the help.


Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de

More information about the Pd-list mailing list