[PD] [declare]: -path seems not to be added to the searchpathes

Roman Haefeli reduzierer at yahoo.de
Mon May 7 17:19:27 CEST 2007

On Mon, 2007-05-07 at 16:58 +0200, IOhannes m zmoelnig wrote:
> Roman Haefeli wrote:
> > hi
> > 
> > i cannot get [declare]'s -path-flag working. i tried relative pathes as
> > well as absolute ones. 
> oh yes, i forgot: that's a problem with [declare]; it only gets executed
> when the patch is loaded....

ah, ok. thanks. however, it works only for the patch, that is containing
the [declare]-object, whereas at the same time a [declare
-lib /path/to/somelib] makes the objects from the external somelib
available for all patches running in the same instance of pd. isn't that
kind of inconsistent?
i hoped, i could use [declare] to get rid of the pd-startup file for
netpd, when netpd is definitely switching to 0.40. but as it works now,
every user made patch would need to have a [declare -path ../abs]. this
is bad news....... it seems, that netpd will always need a
startup-file :-(


Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de

More information about the Pd-list mailing list