[PD] Bug in Pool?

Luke Iannini (pd) lukexipd at gmail.com
Wed May 9 04:24:14 CEST 2007

Hi Thomas (and list),
I have run into what appears to be a limitation with [pool], namely
that it crashes with something around ~780 characters loaded from a
file as values in a key.

I ran into this loading a particularly long list in Memento.  I've
attached a patch and a file from which to load to experience the
crash.  The file is just a little over the character count needed to
crash it (it seems to be between 780 and 800?).  It does not seem to
be a function of the number of elements in the list, but rather the
length of the text in those elements.  Shorten a few of the values in
the list and it loads right up.

I'm also pretty sure this is a per-key limitation, as memento's lddir
first loads files into /tmp before copying them into the proper key.
I've used that with a file that was just under the crashing length and
that worked fine (loaded into two keys).

I have tested this on both my PPC Mac and my Intel Mac; maybe others
can check it out too?

(also to clarify, the problem occurs when loading data from a file;
data of any length (that I've tried) makes it into the pool without
issue, and saves without issue)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PoolCrash.pd
Type: application/octet-stream
Size: 237 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20070508/7670e41d/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: CoscNearlyAll
Type: application/octet-stream
Size: 1054 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20070508/7670e41d/attachment-0001.obj>

More information about the Pd-list mailing list