[PD] Pd and Edirol UA-25

Bryan Jurish moocow at ling.uni-potsdam.de
Thu May 31 01:32:48 CEST 2007

moin Robert,

On 2007-05-30 17:15:06, "Atwood, Robert C" <r.atwood at imperial.ac.uk>
appears to have written:
>> -----Original Message-----
>> On Behalf Of Bryan Jurish
> ...
>> run pd with the "-rt" switch (which required getting realtime
>> capabilities patches working: urgh) when using ALSA directly, 
>> otherwise
>> I get audio pops and eventual "tried but could not sync" 
>> errors.  fyi, I
>> run pd here with:
>> moocow at binky:~$ cat `which pd-ua25.sh`
>> #!/bin/sh
>> ( pd -rt -r 48000 -alsa -channels 2 -audiodev 6 "$@" & )
>> ( sleep 5 ; aconnect-usb2pd.perl; jack-chrt.sh )
> I don't quite follow: are you using JACK or the ALSA connection from pd?
> Or you mean jack-chrt is badly named because it's not actually doing
> anythign wth JACK?

I meant that the script is badly named because it doesn't do anything
with jack (well, to be totally honest, it might tweak jack's priorities
if it finds a jackd running, but I'm not usually running it these days).

I've tried using jack, even gotten things working, but my experiences to
date with pd audio over jack have been less than fantastic, so I haven't
put too much effort into it (contrast with the desktop, where I
need/want to run ardour, but that's a different animal altogether).  As
I recall, the tests I ran with jack and the ua-25 all worked pretty
well, but jack likes to complain when you use the alsa plugin layer
"plughw:2,0" or whatever.  I also used to get subtle but audible pops
every 30 sec or so using jack, and I never figured out why... maybe it's
gone now ;-)

>  I was about to get a UA 25 so am quite interested in how this works.
> With the builtin (intel HDA) I get pops when using JACK but not when I
> use the ALSA output . I did not get the pops with a different
> application, when using JACK, but just when using PD and JACK .. Though
> I've not exhaustively tested all applciations yet. But, I really want to
> get the sound stream from PD into another application and via JACK seems
> like the simplest way. 

... attached is a relevant message I just received off-list which looks
as if it was intended for this thread ...


On 2007-05-30 21:45:44, Olivier Heinry <oli4444 at googlemail.com> appears
to have written:
> Hi,
> here is my running set up for the UA 25 on debian lenny/sid, no kernel
> patch (2.6.18), Alsa compiled via the module-assistant:
> interface in advance mode @48k
> qjackctl runs with the following:
> server : jackd, driver alsa
> Realtime, soft mode  & force 16bit mode ticked
> priority 89, frames/period 256, rate 48k, periods/buffer=3
> dither none
> audio : playback only
> latency=16ms
> pd started as follow:
> pd -r 48000 -rt -jack -audiodev 1 (or whatever your setup, 0 being the
> intel chipset #)
> Midi managed through qjackctl, just fine!
> ++
> O.

Bryan Jurish                           "There is *always* one more bug."
jurish at ling.uni-potsdam.de      -Lubarsky's Law of Cybernetic Entomology

More information about the Pd-list mailing list