[PD] munger1~ ppc mac install problem (revisiting old topic)

Leah Buechley Leah.Buechley at Colorado.EDU
Sun Jul 29 19:21:45 CEST 2007

I'm struggling to install munger1~ on my ppc mac (10.4.1).  I am  
attempting to do a source install.  I can install stk (4.2.1) &  
flext, but can't seem to install munger1~.  Have tried with Pd 40-2 &  

the problem seems to be stk-flex-munger1~ integration...

Here's what I'm doing: (following the munger1~ instructions as  
closely as possible.)  After my stk install, I'm copying libstk.a to / 
usr/local/lib & all of the stk includes to /usr/local/include. I'm  
installing flext according to instructions.  Then, when I attempt to  
install munger1~, I get this error:

       munger1~.cpp:36:19: error: flstk.h: No such file or directory

I've tried copying all of the flext header files to /usr/local/ 
include.  This solves the above problem, but gives me this error:

        /usr/bin/ld: table of contents for archive: /usr/local/lib/ 
libstk.a is out of date; rerun ranlib(1) (can't load from it)

I get this same error when I attempt to install flext before stk,  
disabling stk support?!?!  (uncommenting the stk line in the flext  
config.txt file).

I've also tried an assortment of hacks to no avail.  Any help would  
be greatly appreciated - especially prebuilt binaries if anyone has  
them!!  see previous discussion of this issue here:  http:// 

thank you!!!


Leah Buechley
Craft Technology Group
Department of Computer Science
University of Colorado at Boulder

More information about the Pd-list mailing list