[PD] who is using [entry]?

Tim Boykett tim at timesup.org
Wed Nov 14 18:07:15 CET 2007

hi all,

maybe a silly question, but:

might it be feasible to use something like tk_text as the name
so as to make it obvious which one is being used without having to fight
with the namespace issues?

this has probably been discussed to death in the namespace conversation
a few months ago....


On 14/11/2007, at 3:12 AM, Hans-Christoph Steiner wrote:

> On Nov 13, 2007, at 6:54 PM, Frank Barknecht wrote:
>> Hallo,
>> Hans-Christoph Steiner hat gesagt: // Hans-Christoph Steiner wrote:
>>> Now I am going to apply what I have learned to a how library  
>>> based on
>>> the Tk widgets.  I am naming them after the Tk widgets, so that  
>>> would
>>> mean making an object called [entry] with is a text entry box, and
>>> renaming the currently [entry] to [text].
>> As [text] is a pretty common word, that could mean anything, it came
>> to my mind: Do you plan some kind of namespace for the new GUI
>> objects?
> I want to keep the same names as the Tk widgets, that's why I chose
> that name.  That way it's very easy to use the Tk docs for these
> widgets.  The options are the same too.  It will be in the lib
> tkwidgets, so tkwidgets/text will always be possible.  Hopefully this
> doesn't cause any problems.
> These are the widgets I plan on implementing:
> http://puredata.info/dev/TkWidget
> .hc
> ---------------------------------------------------------------------- 
> --
> ----
> There is no way to peace, peace is the way.       -A.J. Muste
> _______________________________________________
> PD-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/ 
> listinfo/pd-list

More information about the Pd-list mailing list