[PD] (linux) libraries loading problem

IOhannes m zmoelnig zmoelnig at iem.at
Fri Nov 23 09:46:45 CET 2007


yvan volochine wrote:
> Hi all.
> I'm new to pd (and linux) and this is my 1st post here so forgive me
> if this is a dumb question.
> I just installed pd-0.39.3-extended on ubuntustudio (v7.04, updated).
> Everything went fine except none of my libraries loads on startup.
> I also installed the following packages:
> build-essential / tcl8.4-dev / cdbs / tk8.4-dev / libasound2-dev /
> debhelper / libjack0.100.0-dev / x-windows...
> I triple checked the doc, my default.pdsettings, my path and startup
> in pd... I always get the same error:
> "tried... and failed. Can't load library".
> I must be missing something really obvious here but I'm stuck...
> Thanx for your help.

this tells us 2 things:

1: you have installed Pd fine and it runs (all the necessary libraries 
are installed (as you have demonstrated with your list of packages); 
there are no dependency problems on the pd side

2: you fail to load a pd-library (aka "external"; in other applications 
this might be called "plugin"), either because this external/library is 
not installed or because it is missing a dependency (externals can 
depend on other stuff; e.g. Gem will depend (among other things) on 
openGL, whereas Pd itself does not)

Pd's externals/libraries are files called <libname>.pd_linux (on linux; 
on other OS's the suffix will be different); these files are searched by 
Pd in several paths, which you can specify with the "-path" option when 
running from the cmdline, or via the "path..." dialog.
by default, Pd searches the path "<path/to/pd>/extra" for a library.

so the information we need to help you more is, which library you are 
actually trying to load: Pd will display something like
  tried /home/zmoelnig/oops.l_i386 and failed
  tried /usr/local/lib/pd/extra/oops.pat and failed
  ... couldn't create
rather than
  tried... and failed. Can't load library.

(note that in my version it tells us that it is trying to load "oops" 
instead of "...")

a simple reasone for the error is, that you are just creating a 
non-existing object (e.g. [oops]), which Pd cannot resolv, therefore it 
is trying to load an external that provides [oops] but fails.


More information about the Pd-list mailing list