[PD] gem: can't load library

Agent Engram agentengram at gmail.com
Mon Jan 7 07:40:24 CET 2008

those *are* the things i tried...

>download and install pd-extended (which contains both, pd and gem
this was what I tried to do first.

basically this required that I go to planet CCRMA rebuild my kernal, also
get jack,
once i did that i tried to run the binaries and got the "floating point
error", pd didnt run at all

so i decided to get the extended version source code and build that...


it built with th following installs added
yum install autoconf
yum install tcl
yum install tk
yum install tcl-devel
yum install tk-devel

well that got pd running, but gem is failing. so did the extended source
build gem or not? are more devel packages required that I missed?
>download the gem binaries from the gem site
the only site I know of is http://gem.iem.at/ is this what you are talking
about? I dont not see *gem binaries for linux* on windows, in fact they
recommend on the site building gem, but its my understanding that this comes
with pd extended, which I built, and which is not loading the gem libs.

so i have now tried to build gem and it fails during configure because it
*seems* to not know how to build using gcc...wierd. who uses g++, i dont
even know how to get it.

[root at aalto src]# autoconf configure.ac>configure
[root at aalto src]# chmod 777 configure
[root at aalto src]# ./configure
checking for Base/configLinux.h.in... yes
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking for C++ compiler default output file name... configure: error: C++
compiler cannot create executables
See `config.log' for more details.

this is driving me a little crazy.

On Jan 6, 2008 9:09 PM, Roman Haefeli <reduzierer at yahoo.de> wrote:

> On Sun, 2008-01-06 at 19:13 -0800, Agent Engram wrote:
> > i figured out how to build pd, i needed the tcl-devel stuff.
> >
> > i was hoping that Gem built with it but alas that would be too easy.
> gem is an external and not part of pd.
> > when I run: pd -lib gem i get...
> > gem: can't load library
> >
> because there is no gem installed.
> > so do I have to build Gem? that is a major pain in linux...
> this has nothing to do with linux. Gem is an extension, that provides
> additional funcionality to pd, which isn't in the focus of puredata
> itself. this is completely unrelated to the operating system. in fact,
> there are many ways to get Gem without having to build it.
> - download the gem binaries from the gem site
> - install a gem-package from your distro (i know that debian based
> distros include gem)
> - download and install pd-extended (which contains both, pd and gem, and
> a lot of other externals)
> just in case you decide to build gem yourself, don't forget to install
> also the dev-package for each dependecy.
> roman
> ___________________________________________________________
> Telefonate ohne weitere Kosten vom PC zum PC: http://messenger.yahoo.de

i am an agent implanted into your unconscious when you abducted by the
travelers. look for signs of me in your life.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20080106/edeb7a39/attachment.htm>

More information about the Pd-list mailing list