[PD] Subject: Gem crash in Ubuntu Gutsy

ohiopctech.com opc_inc_fu at hotmail.com
Wed Apr 23 23:44:39 CEST 2008

just my two cents on this issue... 

  i had decided yesterday that i had worked on the audio side of my patch enough and should start working on the graphics side of things and began to study gem. in the examples i found... everything worked fine from the example patches but when i tried to implement the same ideas into my own patch i started getting crashes... i believe it had something to do with the pix_ objects... i am new (but catching on fast) to PD so it may have nothing to do with slimboyfatboyslim's issue.

i'm running on a amd 64bit (in 32bit mode) winXP box. (DX10 i think)
Pd version 0.39.3-extended
GEM: Graphics Environment for Multimedia
GEM: ver: 0.91-cvs
GEM: compiled: Dec 11 2006

btw, puredata is AMAZING!  and here is some videos of me playing with PD and reactivision: http://youtube.com/ohiopctech  and i have posted a two part 45 minute recording session, audio only of me and a buddy playing with the patch i have created/pasted together so far, on my website... part one is the third blog post from the top right now... part two is the second one down.  the audio is running from the amd-winXP box through my kaoss pad.. to another win98 box doing the recording.  (i'm using the kaoss pad for now because i don't have any filter  or cv blobs programmed yet)  i hope someone enjoys the audio recording.. we sure had a blast playing it!  the website is: http://ohiopctech.com

thanks for the time you all have spent making PD what it is today!

-- chr0n1c


Message: 1
Date: Wed, 23 Apr 2008 07:16:04 +0800
From: slimboyfatboyslim at slimboyfatboyslim.org
Subject: [PD] Gem crash in Ubuntu Gutsy
To: pd-list at iem.at
<20080423071604.kfgd91144k0008sk at webmail.slimboyfatboyslim.org>
Content-Type: text/plain; charset=ISO-8859-1; format="flowed"

hi all,

I'm working on PD 0.40 and Gem 0.90 (installed via Synaptic), everything works
fine with PD and pdp but when I create any objects related to Gem GUI (gemwin)
or open a patch with gemwin, it crashes with the output below:

pd -verbose -lib Gem
Pd version 0.40-2
compiled 22:04:28 Dec  7 2006
port 5400
TK_LIBRARY="/usr/lib/pd/tk/library" "/usr/lib/pd/bin/pd-gui" 5400
Waiting for connection request...
.. connected
OSS: requested audio buffer size 8816 limited to 8192
OSS: issuing first ADC 'read' ... ...done.
socket receive error: Connection reset by peer (104)
Segmentation fault (core dumped)

Same situation if I work as root (except it connects to port 5401)
seems to be some problems with tcl/tk but I've installed the latest from
Synaptic, P.S I'm working on MacBook

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20080423/57ccb5ee/attachment.htm>

More information about the Pd-list mailing list