[PD] netpd broken?

Max Neupert abonnements at revolwear.com
Thu May 29 15:14:08 CEST 2008

ok here my findings:

after another
[declare -path /Users/max/Desktop/netpd/includes]
i could not make an object like [netpd-f]

strange thing is: that even after adding the path to the paths- 
preferences of pd, then restarting pd + netpd there was still no  
chance to make a netpd object.

and yes, the path was right.

i tested it without netpd and it works there (made a folder somewhere  
with a patchname testerx.pd included the path to that in the paths  
and used it in a new file) that works.

i thought the ui-work may heve broken the paths all in all but that's  
not the case.

maybe i have some time tomorrow to give it another try.

this is todays autobuild on ppc osx 10.4


Am 2008-05-29 um 21:02 schrieb Roman Haefeli:

> On Thu, 2008-05-29 at 20:42 +1000, Max Neupert wrote:
>> Am 2008-05-29 um 19:54 schrieb Roman Haefeli:
>>> On Thu, 2008-05-29 at 19:27 +1000, Max Neupert wrote:
>>>> servus roman, list,
>>>> i wanted to demonstrate netpd today here in melbourne and failed.
>>>> on a intel mac os x 10.5:
>>>> with a fresh pd-extended 0.4xx and downloaded netpd.zip i can open
>>>> _chat.pd. then when i click on creator additionally a blank patch
>>>> pops up called "pd cr.singletons" the console spills out:
>>>>   netclient
>>>> ... couldn't create
>>>> error: inlet: expected '' but got 'connect'
>>>> ... you might be able to track this down from the Find menu.
>>>> error: pd-cr.singletons: no such object
>>>> i can reproduce the same on my own machine os x 10.4 ppc.
>>> [netclient] is part of maxlib. afaik, it should be found in
>>> extra/maxlib. netpd/_chat.pd has a [declare] in order to add the
>>> path of
>>> the maxlib folder. if it doesn't load, either [declare] on those
>>> versions of pd-extended are broken or netclient was moved. i'll  
>>> have a
>>> look at that soon. probably it is just a matter of using an
>>> appropriate
>>> [declare].
>> ok, with [import maxlib] i could make the netclient object.
>> but the rest of the problem is still there: when i open the creator
>> an empty patch pops up called "pd cr.singletons" and creator doesn't
>> work properly. i think it is probably that i need to declare the
>> "include" direcory..
> exactly.. actually it should be [declare]d already (i checked and  
> it is
> in _chat.pd).
> probably you could check, if it is working, by creating a subpatch
> somewhere in the _chat.pd patch and then trying to create [netpd-r]  
> (or
> any other abstractions from netpd/includes). if it fails, then for  
> some
> reason [declare -path] doesn't work on your version of pd-extended. a
> recent build most likely already has fixed the issue. i haven't kept
> track of what works in which version, but i think, with the coming
> release of 0.40-extended many things should be solved.
> roman
> ___________________________________________________________
> Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo!  
> Mail: http://mail.yahoo.de

-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: Signierter Teil der Nachricht
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20080529/c9a79d8e/attachment.pgp>

More information about the Pd-list mailing list