[PD] Grokking [declare]

Mike McGonagle mjmogo at gmail.com
Sat Jun 7 06:15:37 CEST 2008

Hello all,
I have been following the development of [declare], but sadly every time I
have tried to use it, it doesn't appear to work as the help file says it

I have tried it several different ways:

1. [declare -stdpath extra/zexy]
2. [prime] <-- from zexy

the [prime] object doesn't get created...

version 2:

1. [declare -stdpath zexy]
2. [prime]

still no joy...

I also tried the same thing, only using -stdlib, but that doesn't seem to
load anything either.

Next I tried to do something relative to a project folder in my home
directory. Inside there, I created a subfolder named 'more' (as in the help
file), and in that I have a file 'abstract.pd'. I made a patch in the root
of the project, and used this

1. [declare -path more]
2. [abstract]

the [abstract] object doesn't get created.

I am running Mac OS 10.4.11, running on PPC hardware. I used the latest
version of PD Extended (the 0.40.3-extended-20080603). I also tried these
same things with Vanilla PD 41.4, and got the same results.

Is there some test patch out there that I could use to test these things?



Peace may sound simple—one beautiful word— but it requires everything we
have, every quality, every strength, every dream, every high ideal.
—Yehudi Menuhin (1916–1999), musician
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20080606/48816c8a/attachment.htm>

More information about the Pd-list mailing list