[PD] better tabread4~

Hans-Christoph Steiner hans at eds.org
Tue Jun 24 12:17:02 CEST 2008

On Jun 24, 2008, at 11:36 AM, IOhannes m zmoelnig wrote:

> Hans-Christoph Steiner wrote:
>> "tabread4~" isn't such a great name that it should be used for  
>> the  new one.
> hmm, from my elitist point of view, [tabread4~] tells me something  
> about how this object works (its reading a table using 4 point  
> interpolation) rather than [tabread_tweak~] which tells me exactly  
> nothing apart from being a modified version of [tabread~] which  
> might do what i want or not.
> certainly the exact meaning of the elements "tab" "read" "4" and  
> "~" is something you have to get used to or learn by heart. but at  
> least they make sense, once you know them.
> this might be the reason why i prefer [lop~] over [cool_filter~]  
> and Pd over reactor.
> fgmasdr
> IOhannes

"4" stands for 4-point interpolation, that is true.  But there are  
many algorithms for 4-point interpolation, as this thread as laid  
bare.  tabread4~ could also describe something that reads 4 values  
and averages them, it could also be the 4th version of tabread~.   
Those are all existing naming conventions in Pd.

Feel free to critique my suggestions, but it isn't really productive  
until there are suggestions for how to do it differently, rather than  
merely saying my suggestion is bad.

How about putting the algorithm name in there somehow?



"[T]he greatest purveyor of violence in the world today [is] my own  
government." - Martin Luther King, Jr.

More information about the Pd-list mailing list