[PD] better tabread4~
IOhannes m zmoelnig
zmoelnig at iem.at
Tue Jun 24 13:07:45 CEST 2008
Hans-Christoph Steiner wrote:
> "4" stands for 4-point interpolation, that is true. But there are
> many algorithms for 4-point interpolation, as this thread as laid
> bare. tabread4~ could also describe something that reads 4 values
> and averages them, it could also be the 4th version of tabread~.
> Those are all existing naming conventions in Pd.
true that "4" doesn't say much about the interpolation alogrithm and
that is definitely a weakness in the current naming scheme.
it was not my intention to say that the current scheme is the
non-plus-ultra in sophistication. it, however, was my intention to say
that [tabread_tweak~] is one of the worst possible names i could think of.
i do not say that this is is "constructive" criticism, rather i meant it
as a preventive criticism.
More information about the Pd-list