[PD] better tabread4~

Charles Henry czhenry at gmail.com
Wed Jun 25 00:00:22 CEST 2008

I disagree entirely with the trend of this discussion towards naming
or methods to choose an interpolation method.

 We need not get ahead of ourselves, when we don't even know if it's a
"better tabread" (like the name of this discussion).  Let's make sure
this thing is solid and finds good usage before expanding the
tabread4~ code with extra methods.

It's nice to have descriptive names for the different interpolation
schemes, but there is a big difference for naming them according to
what they do or how they're used, as Matju said.  I see no problem
with shortening the names, because it's not practical to name these
things concisely, e.g.  "tabread4_continuous_first_derivative~" or

So, what's wrong with tabread4c~ or tabread4a~?  plenty of
alternatives, but really, this is short and memorable, while keeping
with the notion that these are small differences from the original

I think it's best to consider making a library of tabread4~
alternatives, and later consider moving the different interpolation
schemes to tabread4~ methods, if it's worth-while.


On Tue, Jun 24, 2008 at 4:12 PM, bsoisoi <bsoisoi at mac.com> wrote:
> I agree, being able to specify interpolation via an inlet message would be
> great (from my users perspective).
> Plus, deciding you want better interpolation (or none at all) in any given
> abstraction would not require the touching of code, which is a big + in my
> opinion.  Sometimes I may want quality, sometimes not, and other times I
> don't know yet or might want to change it on the fly.
> That's what always bugged me about Reaktor's table object, you have to
> right-click on the table in the setup and enable interpolation manually,
> which to me is the equivalent and equally annoying to  specifying a
> different object in Pd.  If you have many of these in your app hunting is
> not very fun.
> Cheers m8s,
> ~brandon
> On Jun 24, 2008, at 10:25 AM, Frank Barknecht wrote:
> Hallo,
> Hans-Christoph Steiner hat gesagt: // Hans-Christoph Steiner wrote:
> "4" stands for 4-point interpolation, that is true.  But there are
> many algorithms for 4-point interpolation, as this thread as laid
> bare.  tabread4~ could also describe something that reads 4 values
> and averages them, it could also be the 4th version of tabread~.
> Those are all existing naming conventions in Pd.
> I'm still fond of using only a single [tabread4~] object and being
> able to specify the type of 4-point interpolation to use with a
> [interpolate cubic( message or so. Additionally with a "-interpolate
> cubic" argument, maybe. Less strain on the global namespace and
> backwards compatible.
> Ciao
> --
> Frank Barknecht                                     _ ______footils.org__
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management ->
> http://lists.puredata.info/listinfo/pd-list
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management ->
> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list