[PD] Trying to compile latest extended on 64-bit (K)Ubuntu

Darren Landrum darren.landrum at sbcglobal.net
Mon Sep 22 02:13:31 CEST 2008

Darren Landrum wrote:
> Hans-Christoph Steiner wrote:
>> cd packages/linux_make/
>> make install && make package

To try to narrow down the possibilities, I decided to delete the 
directory and re-unpack the tarball, then I ran your instructions 
(without doing anything else) and got this output:

darren at ashe:~/Downloads/Pd-0.40.3-extended/packages/linux_make$ sudo 
make install && make package
/home/darren/Downloads/Pd-0.40.3-extended/packages/linux_make/build/: No 
such file or directory
dpkg-shlibdeps: need at least one executable

make -C /home/darren/Downloads/Pd-0.40.3-extended/packages 
prefix=/usr OPT_CFLAGS="-O2" UNAME=Linux install
/home/darren/Downloads/Pd-0.40.3-extended/Gem/src/Base/GemVersion.h: No 
such file or directory
make[1]: Entering directory 
cd /home/darren/Downloads/Pd-0.40.3-extended/pd/src/ && \
         if [ -f acinclude.m4 ] ; then aclocal ; fi && \
         autoconf && \
         if grep -q AC_CONFIG_HEADERS configure.in ; then autoheader ; fi
/bin/sh: aclocal: not found
make[1]: *** 
[/home/darren/Downloads/Pd-0.40.3-extended/pd/src/configure] Error 127
make[1]: Leaving directory 
make: *** [install] Error 2

Hopefully, that will help. (The sudo also doesn't make a difference. I 
get the same error with or without it.) Sorry to be a pain.

Darren Landrum

More information about the Pd-list mailing list