[PD] [GEM] ps3eye camera on linux / OSX?

Jaime Oliver jaime.oliver2 at gmail.com
Tue Jun 30 05:31:42 CEST 2009

Hi Martin, Iohannes,

I have attempted to get the ps3eye working in linux, and have that same
error you have. it works fine in mplayer, ut not in gem

I am trying to get the libv4l-devel package for fedora 8, but can't find it.
do any of you know where can I find it or have a file?



On Thu, May 14, 2009 at 1:57 AM, Martin Schied <crinimal at gmx.net> wrote:

> Martin Schied schrieb:
>  Jaime Oliver schrieb:
>>> Hi,
>>> I have changed the subject to [GEM] if perhaps people have missed
>>> it... it would be great if anyone else is interested in this because
>>> to have a 120fps camera for less than 40$ working in GEM would be
>>> amazing...
>>> When was the las time you tried this driver?
>>> I'm getting one of these cameras at some point this week to try it
>>> out. It seems that with that driver you can get a video0 device, but
>>> you can only change settings when you load the driver and therefore
>>> not through pix_video...
>>> I'll let you know if I have any success.
>> yeah, that would be really great and also was one of my thoughts when
>> buying that cam. i already tried several resolutions + fps at module load
>> time, wich works for other applications than GEM. that was approximately one
>> week ago. but i'm not sure if it was the latest driver available though. I
>> made a flickr account, so I'll be able to upload some pictures of the errors
>> later.
> ok. this is what I get into GEM (pd extended, nightly one or two weeks ago,
> sorry for not being that precise...), ubuntu 9.04
> http://www.flickr.com/photos/38404107@N08/sets/72157618127535288/
> one "clear" picture from cheese for comparison.
> As I'm still on ubuntu 8.04 for work i tried to compile "MT gspca modified
> driver V0.5" for it, but this kernel seems to old for these modules.
> so this is all from ubuntu jaunty 9.04:
> modinfo:
> filename:
> /lib/modules/2.6.28-11-generic/kernel/drivers/media/video/gspca/gspca_ov534.ko
> license:        GPL
> description:    GSPCA/OV534 USB Camera Driver(kaswy mod for MT use V0.5)
> author:         Antonio Ospite <ospite at studenti.unina.it>
> srcversion:     2669EC48DECC8E6AB8C781B
> alias:          usb:v1415p2000d*dc*dsc*dp*ic*isc*ip*
> depends:        gspca_main
> vermagic:       2.6.28-11-generic SMP mod_unload modversions 586
> parm:           videomode: = xx //Set the videomode(see doc) (int)
> parm:           autogain: = [0|1] //Autogain (agc,aec,awb) (bool)
> parm:           gain: = [0..63] //main gain (int)
> parm:           exposure: = [0..255] //Exposure (int)
> parm:           redblc: = [0..255] //Red Balance (int)
> parm:           blueblc: = [0..255] //Blue Balance (int)
> parm:           sharpness: = [0..63] //Sharpness (int)
> parm:           vflip: = [0|1] //Vertical flip (bool)
> parm:           hflip: = [0|1] //Horizontal mirror (bool
> when i start rendering i get these messages repeatedly (every frame?) in
> console output:
> VIDIOCSYNC: Invalid argument
> VIDIOCSYNC: Invalid argument
> VIDIOCMCAPTURE1: Invalid argument
> VIDIOCMCAPTURE2: Invalid argument
> when changing dimen in pix_video:
> error: x dimensions too great
> error: y dimensions too great
> see flickr images for differences when using RGB, grey, YUV
> camera has been set to 640x480 before. I also tried different videomode
> settings at module load time, without difference for these errors.
> cheers
> Martin

Jaime E Oliver LR

joliverl at ucsd.edu

858 202 1522
9168 Regents Rd. Apt. G
La Jolla, CA 92037
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20090629/55caa2f2/attachment.htm>

More information about the Pd-list mailing list