[PD] Problems with DIO errors / audio clicking

danomatika danomatika at gmail.com
Wed Jul 29 14:05:11 CEST 2009

> I'm having problems with DIO errors and glitchy audio with
> PD-extended 
> 0.41.4
> My computer is an HP Compaq nc6000 1.6Ghz laptop with 500mb RAM and
> I'm 
> running Ubuntu 9.04.
> The kernel is 2.6.28-13-generic and I've tried using the realtime
> kernel 
> which is 2.6.28-3-rt but it's no different. I've tried editing 
> /etc/security/limits.conf to include the lines:
> @audio - rtprio 99
> @audio - nice -19
> @audio - memlock unlimited
> but this hasn't helped either.
> I start jack with qjackctl and my settings are:
> Realtime, No Memory Lock, Frames/Periods: 1024 sample rate 44100, 
> Periods/Buffer: 2,.
> Can anyone help?

If you installed Intrepid or Jaunty from scratch, there is no audio
group created by default and the limits.conf additions won't work.  Add
an audio group and add your user to it.  Running pd or jack in realtime
should work.  I had smooth performance on my old Thinkpad T42 with
comparable specs.

Dan Wilcox
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20090729/6b98fa34/attachment.htm>

More information about the Pd-list mailing list