[PD] Building PD-extended

Hans-Christoph Steiner hans at at.or.at
Sun Aug 9 20:50:17 CEST 2009

Ok, I fixed this issue and committed it to SVN.  So you should be able 
to run the 0.41.4 autobuild on more machines.  I just ran a successful 
build on Ubuntu Netbook Remix Jaunty, which I'll be posting soon.


el jay wrote:
> yes i have tried this..  buit then when i try to build  with
> fakeroot dpkg-deb --build build/ Pd-0.40.3-extended.deb
> i get given the same error.. and if i touch around some more then i am told that package name was expected but is missing or garabe found
> 2009/7/27 danomatika <danomatika at gmail.com <mailto:danomatika at gmail.com>>
>     On Mon, 2009-07-27 at 04:18 +0200, pd-list-request at iem.at
>     <mailto:pd-list-request at iem.at> wrote:
>>     hello pd'people!
>>       i am trying to install Pd.extened-41.4 on a debian64 sid (unstable)
>>     kernel 2.6.30-
>>      i have been looking around and the option of installing 32bit with
>>     ia32lbs an ---force-architecture
>>      gave me libsasound2 problems..
>>         so i found a tutorial that explain how two build from source for
>>     64bits..   i have managed to compile the extended libraries.. and run
>>     make install && make packages... here everything gives the ok..  and
>>     then after compiling for a while  it gives me an error saying that i
>>     have a problem with DEBIAN/control file on line 9.. in "depends"
>>     field,
>>     that i its missing a packages name or that garbage has been found..
>>       when checking this file.. in the place of dependes it says: xterm,
>>     ttf-bitsream-vera
>>     i dont really understand what the problem is.. can somebody helpme
>     It's probably missing a comma: xterm,
>     ttf-bitsream-vera<----------- add ',' here.
>     I had the same problem
>     (http://puredata.info/docs/developer/BuildingPdExtended64bitUbuntuIntrepid):
>         If, like me, you get an error similar to this:
>         dpkg-deb: parse error, in file
>         /home/dano/Desktop/pd-build/Pd-0.40.3-extended/packages/linux_make/build//DEBIAN/control
>         near line 8 \package pd-extended: Depends field, syntax error
>         after reference to package zlib1g make: *** deb Error 2
>         then there is a comma missing after a dependency. Open the
>         Debian control file, look through the dependency list on line
>         8, and add the missing comma(s) after the referenced package
>         in the error, in this case "zlib1g":
>     ---
>     Dan Wilcox
>     danomatika.com <http://danomatika.com>
>     robotcowboy.com <http://www.robotcowboy.com>
> ------------------------------------------------------------------------
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list