[PD] can't view list of an array

Hans-Christoph Steiner hans at at.or.at
Mon Aug 31 21:19:16 CEST 2009

Hey Ariane,

Its a known bug in that version of Pd-extended.  Pd-vanilla does not  
have it.  Its fixed in Pd-extended 0.42.5, but that build is still  
pretty rough.  You can edit the pd.tk file in your Pd-extended.app,  
its a simple, one line fix.

Basically, right-click on Pd-extended.app, chose Show Package  
Contents.  In there, navigate to:
Contents -> Resources -> bin  and then open "pd.tk" in your favorite  
text editor.  Then on line 3556, you'll see the text on the left of  
the web page below, you want to change it to the text on the right.



On Aug 28, 2009, at 9:01 PM, Ariane stolfi wrote:

> Hi,
> I'm trying to view the list of an array
> and I'm gettin this error
> _________________________________
> wrong # args: should be "array_viewlist id"
> wrong # args: should be "array_viewlist id"
>    while executing
> "array_viewlist .gfxstub7e0270 table10 0"
>    invoked from within
> ".gfxstub7e0270.listview invoke"
>    ("uplevel" body line 1)
>    invoked from within
> "uplevel #0 [list $w invoke]"
>    (procedure "tk::ButtonUp" line 23)
>    invoked from within
> "tk::ButtonUp .gfxstub7e0270.listview"
>    (command bound to event)
> _________________________________
> I had tried the same in other arrays and always got the same error
> I'm using
> Pd version 0.41.4-extended
> in a intel mac OSX (leopard)
> Is there some fix for this?
> thanks
> Ariane
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list


"[W]e have invented the technology to eliminate scarcity, but we are  
deliberately throwing it away to benefit those who profit from  
scarcity."        -John Gilmore

More information about the Pd-list mailing list