[PD] xsample freezes PD

altern altern2 at gmail.com
Sat Sep 12 06:20:03 CEST 2009

i just compiled it from svn source and it is working fine. much easier 
than last time, i am getting good at this ;)


Thomas Grill(e)k dio:
> Hi Enrike,
> i'm afraid i can't help too much.... i'll recommend that you try to
> compile the object on your system (flext and xsample) instead of using
> the binary.
> It would also be helpful to know where exactly it freezes (running in
> gdb and printing the backtrace).
> I'm abroad and therefore not able to build anything until the end of
> September, but let's see if we get it running.
> gr~~~
> 2009/9/11 altern <altern2 at gmail.com>:
>> hi
>> when i run some of my patches the pd process goes to 99% CPU and the pd GUI
>> freezes, i cannot close
>> the terminal or any patch. I have to kill the process from task manager.
>> After some tests and found out that it seems to come from xgroove~
>> object. This is how it happens: I run pd, open the xgroove~ object help
>> file, setup pd input and output devices via ALSA. I activate DSP and
>> push the bang to start play the xgroove~ example.
>> The audio runs until the playhead goes next to around 80% of the table then
>> it
>> freezes, i can see that the PD CPU usage grows quickly just after the audio
>> and GUI freeze.
>> any ideas? this is the terminal output. not very interesting i guess.
>> ~$ pd
>> <init> : Avifile RELEASE-0.7.47-070929-17:56-4.2.1
>> <init> : Available CPU flags: fpu vme de pse tsc msr mce cx8 sep mtrr
>> pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2
>> <init> : 1600.00 MHz Intel(R) Pentium(R) M processor 1.60GHz detected
>> pd_gui: pd process exited
>> Killed
>> xsample external seems to be loaded properly, pd console says this on
>> startup
>> -------------------------------
>> xsample objects, version 0.3.2pre
>>  xrecord~, xplay~, xgroove~
>>  (C)2001-2008 Thomas Grill
>> -------------------------------
>> there is no message post into the console when the error happens.
>> This happened both in PureDyne with the pd installed from their packages and
>> also in Ubuntu Studio with the pd extended package. Both systems running
>> latest xsample binary from http://puredata.info/Members/thomas/xsample
>> I guess it is either a bug in latest version of xsample or I am missing
>> something in both systems.
>> thanks
>> enrike
>> _______________________________________________
>> Pd-list at iem.at mailing list
>> UNSUBSCRIBE and account-management ->
>> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list