[PD] possible bug with iem_pbank_csv

Malte Steiner steiner at block4.com
Wed Dec 2 04:06:26 CET 2009


first thanks to Thomas Musil for all his work on PD, its great! I think 
I have discoverd a bug in iem_pbank_csv, maybe its specific to my 
machine. When I write the data to disk and load it back I have only 
access to the first line. When I open the resulting .csv in an editor I 
see that all lines are there and that the data is stored correctly.
I tried with different settings for delimiters and linebreaks but with 
same results. Same goes for the original helppatch.
Last experiment I did with the example, copying the original csv file 
and than store another one with the same data. Again, when I reload it, 
it has suddenly only access to the settings from the first line while 
the original worked. When I compare the two files I can see a slightly 
difference, the good and working one as 2 bytes for linebreak (cr/rt 
perhaps) while the new one only has one.

At the moment I use pd-extended 0.42.5 on Arch Linux in 32bit. I try to 
look in the source code of that module, maybe I find that bug, seems simple.


media art + development
follow me on Twitter:
or face the book:

More information about the Pd-list mailing list