[PD] no audio in -nogui mode

Hans-Christoph Steiner hans at at.or.at
Thu Dec 3 19:22:49 CET 2009

On Nov 30, 2009, at 3:53 AM, IOhannes m zmoelnig wrote:

> Hans-Christoph Steiner wrote:
>> So I have a Debian/stable box for a sound installation and I want  
>> to run
>> pd with -nogui on it.  But it is acting insane.  Basically, when I  
>> run
>> Pd with a GUI, everything works fine.  When I add -nogui, pd can't
>> read/write the audio devices.  I've tried:
>> - ALSA and OSS
>> - root and other users
>> - Pd-extended 0.41.4 and 0.42.5 and Pd-vanilla 0.41.4
>> Here's what I get with OSS:
>> pd at arg:~$ pd -nogui /tmp/test.pd
>> /dev/dsp (read/write): Device or resource busy
>> (now will try write-only...)
>> /dev/dsp (writeonly): Device or resource busy
>> /dev/dsp (readonly): Device or resource busy
>> audio I/O stuck... closing audio
> https://sourceforge.net/tracker/?func=detail&aid=2724318&group_id=55736&atid=478070
> i thought that approximately 3 or so people (including you) on the  
> world
> would have a good overview on the open bugs in the tracker :-)

Too much information... running thru my brain.  I can't keep track of  
it all.  It did make me think it would be awesome to have a search on  
puredata.info that also searched sourceforge and pdpedia.

Anyway, that workaround worked for me.  Has anyone looked at this bug  
before?  Any ideas?  Is it complicated?



News is what people want to keep hidden and everything else is  
publicity.          - Bill Moyers

More information about the Pd-list mailing list