[PD] [PD-announce] gem 0.92.2 released!

Jaime Oliver jaime.oliver2 at gmail.com
Tue Dec 15 22:46:55 CET 2009

thanks, that seems to make it compile, but with a lot of warnings of the kind:

ld: warning: in ./Objects/world_light.o, file is not of required architecture

for just about every object.

I do get a Gem.pd_darwin

but get the following messages from pd when loading:

tried /Applications/gem-0.92-2/src/Gem.d_fat and failed
tried /Applications/gem-0.92-2/src/Gem.pd_darwin and succeeded
dlopen(/Applications/gem-0.92-2/src/Gem.pd_darwin, 10): no suitable
image found.  Did find:
	/Applications/gem-0.92-2/src/Gem.pd_darwin: mach-o, but wrong architecture
/Applications/gem-0.92-2/src/Gem: can't load library

again I attach the config.log



On Tue, Dec 15, 2009 at 4:16 PM, chris clepper <cgclepper at gmail.com> wrote:
> -arch i386
> On Tue, Dec 15, 2009 at 4:12 PM, Jaime Oliver <jaime.oliver2 at gmail.com>
> wrote:
>> > ld: warning: in
>> > /System/Library/Frameworks//QuickTime.framework/QuickTime,
>> > missing required architecture x86_64 in file
>> >
>> > Try forcing a 32 bit build.
>> would I achieve that by removing the -fPIC flag?

Jaime E Oliver LR

joliverl at ucsd.edu

858 750 0924 (cel)
858 202 1522 (home)
9168 Regents Rd. Apt. G
La Jolla, CA 92037
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 85929 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20091215/1bcb0548/attachment.obj>

More information about the Pd-list mailing list