[PD] Re 2: pd~ for Max

Johannes THIS_IS_POP at web.de
Sun Feb 21 00:17:15 CET 2010

hello list,

i just tried the pd~object (using pd - 0.42.5) in max 4.6 on osx and
it works for me now - with some troubles.

when i am changing the amplitude of the singnal, wich gets into the 
first and
second inlet of pd~, via an message in the first inlet of pd~,
i get some dropouts and then max freezes totally. the problem don´t 
appear when
i am changing the signal, wich is generated inside of the sub-process.

anyone with the same problem?
whats the reason for that issue?


Max schrieb:
> Ted Apel hs updated his site, pd~ is now available here:
> http://crca.ucsd.edu/~tapel/software.html
> but it still doesn't work for me with Max5.
> Am 01.09.2009 um 20:06 schrieb fred-ordi:
>> si, it works fine in Max4 osx 10.5.8 with attached file compiled with 
>> max5 sdk.
>> Its quite stable, if I edit the audio in Max patch, with audio 
>> interrupts, Pd is quiting of course but no pb at all to relaod it and 
>> sounds good.
>> The point is that the opendialog in Max help returns the following 
>> pathname:
>> hard-disk-name:/path/to/Pd
>> which does not work in Max -:(, just need to remove hard-disk-name... 
>> (need something like cut -d: -f 2 in Max messag-filemane subpatcher...)
>> but still not work in Max5, Pd does not launch yet.
>> fred
>> marius schebella wrote:
>>> okayyyyyyyyy!
>>> so what I have to do is:
>>> start the help patch with max4,
>>> then open Options - DSP Status
>>> (If I try to open the panel later, I get an error saying
>>> error: Bad file descriptor)
>>> then I had to replace the opendialog with a simple message starting
>>> with "/Users/marius...", as opposed to what I got before
>>> "mac_hd:/Users/marius...".
>>> and then I clicked on this message, pd would start up and spit out a
>>> message with a lot of zeros. and then I start sound as you said from
>>> the DSP Status window.
>>> hmmm... actually trying the whole thing again,
>>> it now works by just starting pd with the pddir message and the start
>>> message and *then* clicking on ;dsp start.
>>> but only once, I cannot stop pd and start it again, that brings me
>>> into freeze mode again..
>>> ah, it works if I turn off dsp in max before stopping pd, and then
>>> start it again, and then turn on dsp again.
>>> marius.
>>> 2009/9/1 Miller Puckette <mpuckett at imusic1.ucsd.edu>:
>>>> No, I mean the Max thing... I don't have Max here, but maybe it's 
>>>> called
>>>> "DSP preferences"?
>>>> cheers
>>>> M
>>>> On Tue, Sep 01, 2009 at 06:07:35PM +0200, marius schebella wrote:
>>>>> hi,
>>>>> thanks miller, are you talking about the pd audio settings? cause the
>>>>> dialog won't open up either, everything is frozen.
>>>>> with physically going in and out, you mean connecting a cable to the
>>>>> mini jack of your macbook(pro)?? should I also say a small prayer? or
>>>>> use my little max voodoo doll.
>>>>> no, seriously, I could still not get it running, sorry.
>>>>> do I need jack for this to work?
>>>>> best, marius.
>>>>> 2009/9/1 Miller Puckette <mpuckett at imusic1.ucsd.edu>:
>>>>>> Hi Marius,
>>>>>> For Max 4, that's the symptom I got -- even after hitting the 
>>>>>> "max DSP 1"
>>>>>> button on the patch -- until I went into the audio settings panel 
>>>>>> and actually
>>>>>> got sound running in and out of hardware. ?For me at least, the 
>>>>>> Max scheduler
>>>>>> apparently didn't even run the DSP objects unless audio was 
>>>>>> physically going
>>>>>> in and out.
>>>>>> For Max5, the API is supposedly unchanged (except, as Thomas 
>>>>>> Grill mentioned,
>>>>>> GUI stuff that pd~ doesn't use). ?However, the scheduler or audio 
>>>>>> I/O
>>>>>> systems might be different for example -- so this is probably 
>>>>>> going to take
>>>>>> some fooling around to debug.
>>>>>> cheers
>>>>>> Miller
>>>>>> On Tue, Sep 01, 2009 at 09:40:09AM +0200, marius schebella wrote:
>>>>>>> Hi,
>>>>>>> I tried to run pd~ on max4 and max5, but no luck either. with 
>>>>>>> max4 i can
>>>>>>> create a pd~ object with inlets and outlets, and when I start 
>>>>>>> pd, the pd
>>>>>>> window starts up, but nothing else happens. max freezes, I guess 
>>>>>>> trying
>>>>>>> to open the pd~-subprocess.pd patch?
>>>>>>> on max5 the situation is exactly the same as fred-ordi 
>>>>>>> described, an
>>>>>>> object box without in and outlets (although in the help-patch there
>>>>>>> *are* ins and outs), and with a message in the max window saying 
>>>>>>> pd~
>>>>>>> version 0.2. but clicking on start pd~... does nothing.
>>>>>>> tried different settings for the directory, too, no change.
>>>>>>> I used 0.42.5. and 10.5.8.
>>>>>>> I can try to compile pd~ for 10.5 later today. is there someone 
>>>>>>> who has
>>>>>>> pd~ running on osx? which versions of max and pd are you using?
>>>>>>> marius.
>>>>>>> Hans-Christoph Steiner wrote:
>>>>>>>> It probably needs to be compiled for Max5. ?Anyone with Max5 
>>>>>>>> want to
>>>>>>>> give it a shot?
>>>>>>>> .hc
>>>>>>>> On Aug 31, 2009, at 3:43 AM, fred-ordi wrote:
>>>>>>>>> yes, here same with Pd-0.42-5 and Max5 on OSX 10.5.8, not yet 
>>>>>>>>> succeed in:
>>>>>>>>> Max window tells nothing about something wrong ("pd~ version 0.2"
>>>>>>>>> printed to Max window when instantiated) but the pd~ object in
>>>>>>>>> pd~.help patcher appears with a dark foreground colorlike if the
>>>>>>>>> external is wrong...
>>>>>>>>> Cheers,
>>>>>>>>> Fred
>>>>>>>>> Miller Puckette wrote:
>>>>>>>>>> Oh... good idea (I have only Max 4; my OS is too old to 
>>>>>>>>>> upgrade to 5)
>>>>>>>>>> thanks
>>>>>>>>>> M
>>>>>>>>>> On Fri, Aug 28, 2009 at 08:32:27PM +0200, Max wrote:
>>>>>>>>>>> pd~ for max does not even launch Pd here.
>>>>>>>>>>> DSP is on.
>>>>>>>>>>> Is there anybody else on the Pd-list who has Max5 installed 
>>>>>>>>>>> on OS X
>>>>>>>>>>> who could try this out?
>>>>>>>>>>> thx, Max
>>>>>>>>>>> Am 28.08.2009 um 19:54 schrieb Miller Puckette:
>>>>>>>>>>>> I had the same problem for a while... for pd~ to work not 
>>>>>>>>>>>> only do
>>>>>>>>>>>> you have to
>>>>>>>>>>>> start "dsp" in the help window but you also have to have audio
>>>>>>>>>>>> going ?in and
>>>>>>>>>>>> out of Max. ?Otherwise Pd start up but does nothing.
>>>>>>>>>>>> cheers
>>>>>>>>>>>> M
>>>>>>>>>>>> On Fri, Aug 28, 2009 at 04:47:11PM +0200, Max wrote:
>>>>>>>>>>>>> I'm having trouble getting it to run - there is no INSTALL
>>>>>>>>>>>>> instructions, but i guess
>>>>>>>>>>>>> pd~.mxo lives in /Applications/Max5/Cycling\ 
>>>>>>>>>>>>> '74/msp-externals/
>>>>>>>>>>>>> and pd~.help lives in /Applications/Max5/Cycling\ 
>>>>>>>>>>>>> '74/msp-help/
>>>>>>>>>>>>> allthough the other files are called .maxhelp, not .help
>>>>>>>>>>>>> i restarted Max and created a pd~ Object, it has no in or 
>>>>>>>>>>>>> outlets but
>>>>>>>>>>>>> i can open the Help from there, switch Audio on and Select 
>>>>>>>>>>>>> the
>>>>>>>>>>>>> Pd-0.42-5.app but nothing happens.
>>>>>>>>>>>>> what am i doing wrong?
>>>>>>>>>>>>> Am 28.08.2009 um 05:35 schrieb Miller Puckette:
>>>>>>>>>>>>>> Oops, sorry about that... I reorganized some stuff and 
>>>>>>>>>>>>>> that fell
>>>>>>>>>>>>>> through a crack. ?It's back up on:
>>>>>>>>>>>>>> http://crca.ucsd.edu/~msp/software.html
>>>>>>>>>>>>>> cheers
>>>>>>>>>>>>>> Miller
>>>>>>>>>>>>>> On Fri, Aug 28, 2009 at 03:21:57AM +0200, Max wrote:
>>>>>>>>>>>>>>> Hi List,
>>>>>>>>>>>>>>> i've been asked by students where to download the 
>>>>>>>>>>>>>>> starter drug ?pd~
>>>>>>>>>>>>>>> for Max? and i could not find it myself - i thought it is
>>>>>>>>>>>>>>> available?
>>>>>>>>>>>>>>> It's neither here:
>>>>>>>>>>>>>>> http://crca.ucsd.edu/~tapel/software.html
>>>>>>>>>>>>>>> nor
>>>>>>>>>>>>>>> http://crca.ucsd.edu/~msp/software.html
>>>>>>>>>>>>>>> and here neither:
>>>>>>>>>>>>>>> http://www.maxobjects.com/?v=authors&initiale=M
> ------------------------------------------------------------------------
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list


Johannes Krause


*sounds sounds sounds*


More information about the Pd-list mailing list