[PD] problems getting openCV to work in pd (pix_opencv) on OSX 10.6

Pagano, Patrick pat at digitalworlds.ufl.edu
Mon Feb 22 17:51:05 CET 2010

It worked out of the box with the previous version of GEM, the latest wants it re-compiled


-----Original Message-----
From: pd-list-bounces at iem.at [mailto:pd-list-bounces at iem.at] On Behalf Of IOhannes m zmoelnig
Sent: Monday, February 22, 2010 11:40 AM
To: Sebastian Wolf
Cc: pd-list at iem.at
Subject: Re: [PD] problems getting openCV to work in pd (pix_opencv) on OSX 10.6

On 2010-02-22 16:47, Sebastian Wolf wrote:
> hi all,
> I tried to install the OpenCV libary for pure data but it won't work I 
> get the following error:
> /Users/zwolle/Library/Pd/pix_opencv/extra/pix_opencv_threshold.pd_darwin: dlopen(/Users/zwolle/Library/Pd/pix_opencv/extra/pix_opencv_threshold.pd_darwin, 10): Symbol not found: __ZNK12GemException6reportEv
>   Referenced from: /Users/zwolle/Library/Pd/pix_opencv/extra/pix_opencv_threshold.pd_darwin
>   Expected in: dynamic lookup
>  pix_opencv_threshold
> ... couldn't create
> …and since i'm really new to pure data and all that stuff i don't 
> understand what this error means or what i'm supposed to do to solve 
> this; so i hope for your help :(

i think you have to compile Gem yourself.
c++ is not very ABI-stable...


More information about the Pd-list mailing list