[PD] Extended can't load any library except Gem on Windows Vista

Matteo Sisti Sette matteosistisette at gmail.com
Sun Mar 7 19:07:53 CET 2010

Errata corrige: there is one other library that does load, it is "vbap".

And one thing it has in common with Gem is that its folder contains a 
dll file with the same name, namely "vbap.dll". Seems like all other 
libraries don't (though I haven't checked _all_ of them).

So I guess I should add the other directories to path rather than to 
The very strange thing is that it used to work up to a few days ago 

Matteo Sisti Sette escribió:
> Hi,
> The short version: I fresh-installed Pd Extended into the default 
> location (C:\Program Files\pd) and I get:
> cyclone: can't load library
> zexy: can't load library
> creb: can't load library
> ....
> and so on for EVERY library except Gem. The strange thing is that Gem 
> does load, and it is located in pd/extra just like all other libraries. 
> This is really crazy isn't it?
> What can be wrong?
> The long version:
> I had already installed Pd Extended and it used to work fine. It was 
> installed in an "unusual" location: "D:/programmi/pd_extended", where 
> "programmi" is the italian word for "programs" but it is _not_ the 
> default directory for programs in my computer (who speaks spanish, not 
> italian).
> When I installed it, I had to manually modify the "pd-settings.reg" file 
> that adds the libraries to startup, because it uses the wrong location 
> for the registry keys (this has nothing to do with the path where Pd is 
> installed). After that, I had Pd Extended working fine and loading all 
> libraries.
> Also, I have Pd Vanilla installed in another directory, 
> "D:\programmi\pd". I run it using the "-noprefs" option, because 
> otherwise, it would (try to) load the libraries from pd Extended.
> Today, misteriously and without (apparently) touching anything, Pd 
> Extended stopped working, that is it started giving me "cannot load 
> library" messages.
> I tried uninstalling and reinstalling it to the same directory with no 
> luck. So I uninstalled and reinstalled again, this time to the default 
> location C:\Program Files\pd (note disk C which is where the OS is 
> installed, and "Program Files" is the actual system Program Files 
> directory, which is displayed as "Archivos de Programa").
> However the result is the same: "cannot load library" for all libraries 
> except Gem.
> The Gem it is loading is actually the one installed inside the 
> C:\Program Files\pd\extra\Gem directory, which is the same path where 
> all other libraries are located too. I know it because if I rename that 
> gem.dll file, it won't load.
> Please help!
> thanks
> m.

Matteo Sisti Sette
matteosistisette at gmail.com

More information about the Pd-list mailing list