[PD] strange error in console
martin.peach at sympatico.ca
Mon Jun 14 22:40:48 CEST 2010
Hans-Christoph Steiner wrote:
> On Jun 14, 2010, at 3:15 PM, Martin Peach wrote:
>> Mathieu Bouchard wrote:
>>> On Mon, 14 Jun 2010, Martin Peach wrote:
>>>> On today's Pd-extended 0.42.5-rc3 for Ubuntu lucid i386 I get this
>>>> message if I open routeOSC-help:
>>>> error: 'routeOSC-help.pd' is a deprecated name format for a help patch.
>>>> Please rename to 'routeOSC-help-help.pd'!
>>>> I can't find it in the source anywhere. Does anyone know where it's
>>>> coming from?
>>> It's coming from s_path.c, function open_via_helppath, label
>>> gotone_deprecated, line 428.
>> ...which exists only in the pd-extended version I think.
>>> It's because of a bug in mrpeach/osc/routeOSC.c, function
>>> routeOSC_setup, line 146, which reads :
>>> class_sethelpsymbol(routeOSC_class, gensym("routeOSC-help.pd"));
>>> when it ought to be :
>>> class_sethelpsymbol(routeOSC_class, gensym("routeOSC"));
>> Ah yes, thanks. It's fixed in svn now.
> Really, the whole class_sethelpsymbol() function should be removed since
> Pd will automatically assume the classname is the base of the helpfile
> name. That function is only used for times when the help patch has a
> different name than the object, which is bad practice IMHO.
OK I took it out. [unpackOSC] used the help patch for [routeOSC] so I
left that one in.
More information about the Pd-list