[PD] strange error in console
martin.peach at sympatico.ca
Wed Jun 16 01:15:20 CEST 2010
Hans-Christoph Steiner wrote:
> On Jun 15, 2010, at 6:58 AM, IOhannes m zmoelnig wrote:
>> On 2010-06-15 12:48, Matteo Sisti Sette wrote:
>>>> don't mistake "bad practice IMHO" for "bad practice".
>>> Of course. But I meant, "do you really think that....?"
>> me too.
> Yes, I really think that its bad practice to have multiple objects use a
> single help patch. We talked about this at length in the PDDP
> meetings. It makes things confusing to newbies and it usually means the
> shared help patches don't illustrate the individual objects well. The
> only reason to do it that way is laziness IMHO.
Well the original post related to [routeOSC] and [unpackOSC] using the
same help file. I did that because [unpackOSC] is fairly useless on its
own and [routeOSC] won't work without [unpackOSC] ahead of it. Also
[slipenc] and [slipdec] are easier to demonstrate using a single help
patch. Is having two identical patches with different names somehow
better? If I use class_sethelpsymbol the user will get the correct help
patch if they right-click 'help'. I suspect most peeps do it that way
instead of drilling down into the externals looking for help patches.
More information about the Pd-list