[PD] Jack, Pd-extended, Lucid and me.

Olivier Baudu lamouraupeuple at gmail.com
Sun Jul 11 02:39:56 CEST 2010

Thank you Pedro for all your tests and posts...

You said you are on an Ubuntu 9.10.
Do you use the pd-extended 0.42.5 nightly auto-builded or did you build a
0.41.4 for 9.10 ?

On monday, I will try to run my patch with the 0.42.5 rc4 on an Hardy... we
will see if it works or not...

My problem is that I can't install Ubuntu 8.04 on my new laptop because it's
too young for all his hardware to be recognized.
And I confirm that everything is working fine with an Hardy, Pd-ext 0.41.4
and jack from the official repository.


2010/7/7 Pedro Lopes <pedro.lopes at ist.utl.pt>

> I was on the train so I had to kill some time :)
> I tried running jack with buffer size 4k and it worked a lot better, using
> H4 usb audio. Just one instance dropped jack percentage from ~15%to 1/2 %.
> It stopped giving A/D/A sync errors in pd console too. But when I fire the
> second instance... the CPU just bursts to load the patch and once it run
> with a lot of buffer glitches and another time it didn't even load and jack
> got so slow that was zombified.
> Weird thing is a lot of times, the second instance dies, and jack
> survives... thus could imply that pd is actually crashing for some odd
> reason. I should try this in my other Linux too, to see if I can get any
> meaningful information - so far all I did was blab, sorry.
> best of luck with this,
> Pedro
> p.s: I never got this behaviour with any other pd file, should be
> interesting to see what others on this list report using your patch. I
> usually never fire 4 pd instances, but sometimes I use two, on windows I had
> a stupid habit of using zillions (like 5 or more) instances of pd because I
> double clicked a file and he always opened a new instance for that =P But
> never had any trouble.
> On Wed, Jul 7, 2010 at 1:33 PM, Pedro Lopes <pedro.lopes at ist.utl.pt>wrote:
>> Hi Olivier,
>> I dont have much time on my hands now, but I tested your patch in my
>> Ubuntu 9.10 using jack. results:
>> 1) I lauched the first one, it took quite a while and CPU bursted as soon
>> as the patch opened (meaning.. heavy patch :D)
>> 1.1) I draw and played a sequence, audio is okay.
>> 2) I launched the second. Major CPU burst, that pdextended went almost to
>> 90% cpu all the time
>> 2.1) The audio began to glitch. (but no xruns on jack)
>> 3) I launched a pdextended just to play test audio sinewave, it launched
>> fairly quick (of course the CPU was busy with other instances..so not as
>> quick as usual) and played without glitch.
>> I need to test more with more time on my hands, but it seems that its more
>> related to how heavy the script is rather than the jack setup. But i really
>> need to test it further, and change jack latency to see if it affects that
>> much... jack never went past 10% os usage, which is normal for that many
>> instances (sometimes i use pd and renoise, and it goes much higher).
>> My jack setup was:
>> - rt (I have rt kernel)
>> - buffer at 512 and 3 period
>> - using the onboard sound card which is sh*t
>> - my laptop is also sh*t for nowadays standards (AMD 1.9 Turion X2)
>> Best regards,
>> Pedro
>> On Wed, Jul 7, 2010 at 1:14 AM, Olivier Baudu <lamouraupeuple at gmail.com>wrote:
>>> Hi.
>>> I'm going to try to expose the problems I've met during the last two
>>> month dealing with the title of my post.
>>> Sorry if it's confused.
>>> This winter, I used to work on an Ubuntu Hardy, Extended 0.41.4 and with
>>> the jackd and qjackctl from the official repository (by the way, my sound
>>> card is a firewire Presonus Firepod).
>>> I had no problem to use 4 different instances of Pd at the same time
>>> using jackd as sound server. (and I can precise I didn't need RT-kernel to
>>> do what I wanted).
>>> I recently change for Ubuntu Lucid.
>>> So I also change for Pd 0.42.5 (rc4) and the new official jackd and
>>> qjackctl.
>>> If I use the kernel 2.6.32-23, I can play my patch on one instance, it's
>>> stable but the sound crunch a little bit sometimes.
>>> I also can execute my patch on 4 instances, but the sound is awful and 3
>>> minutes later, Jack quit.
>>> So I've try the 2.6.31-11-rt.
>>> In Pd-ext, If I change directly from ALSA to Jack, pd quit. Every time I
>>> have to change to OSS before to choice Jack and I can't save the jack
>>> configuration.
>>> On one instance the sound is perfect and stable.
>>> It's possible to launch 4 instances without patch and to hear
>>> simultaneously the 4 tests tones on my sound card using jack.
>>> But it's impossible to launch even 2 instances with my patch.
>>> Both quit at the same time when I try to pass from OSS to Jack on the
>>> second.
>>> Console message just tell me that GUI of Pd have quited.
>>> My patch is the one you can find on this page :
>>> http://yamatierea.org/papatchs/squareroom/OSR.htm
>>> Direct link for the patch :
>>> http://yamatierea.org/papatchs/squareroom/OSR.zip
>>> But be careful if you look inside... it's still a little bit fuzzy...
>>> Do you think there is a way to solve my problem ?
>>> --> Using my patch, simultaneously on 4 instances of Pd-extended using
>>> Jack on Ubuntu 10.04?
>>> Thank you.
>>> 01ivier
>>> _______________________________________________
>>> Pd-list at iem.at mailing list
>>> UNSUBSCRIBE and account-management ->
>>> http://lists.puredata.info/listinfo/pd-list
>> --
>> Pedro Lopes
>> contacto: jazz at radiozero.pt
>> website: http://web.ist.utl.pt/Pedro.Lopes
> --
> Pedro Lopes
> contacto: jazz at radiozero.pt
> website: http://web.ist.utl.pt/Pedro.Lopes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20100711/4bd7b283/attachment.htm>

More information about the Pd-list mailing list