[PD] pdpcap 0.0.4 network sniffer new version
matju at artengine.ca
Fri Oct 1 14:20:09 CEST 2010
On Thu, 30 Sep 2010, Jordi Sala wrote:
> Yes it can be renamed, I named pdpcap when I started the object
> (PD+PCAPlib)...,... pcap could be a good name....any suggestions?
name the package "pd-pcap" and the pd library file "pcap.pd_linux" for
Several programming languages use such naming... the hyphen makes it like
a namespace in the package-manager, and the complete lack of the "pd-"
prefix in the context of pd makes it look like you're loading the original
"pcap" itself into Pd (which, of course, makes a lot more sense if that's
exactly what your lib does : a plain wrapper and nothing else). I think
that this is the kind of naming that users of several other programming
languages have come to expect (Perl, Python, Tcl, Ruby, PHP, etc.)
| Mathieu Bouchard ------------------------------ Villeray, Montréal, QC
More information about the Pd-list