[PD] pdpcap 0.0.4 network sniffer new version
poperbu at gmail.com
Fri Oct 1 19:57:54 CEST 2010
Hans, so your proposal is to split the current pdpcap in 2 different
objects: one for live (net device) capturing and a second one for pcap file
I like Mathieu's suggested name:1) the Mathieu's reasoning about naming,
2)the objects I think is differentiated of pdp, 3)doesn't lost enterely his
original name pd-pcap,
On 1 October 2010 14:20, Mathieu Bouchard <matju at artengine.ca> wrote:
> On Thu, 30 Sep 2010, Jordi Sala wrote:
> Yes it can be renamed, I named pdpcap when I started the object
>> (PD+PCAPlib)...,... pcap could be a good name....any suggestions?
> name the package "pd-pcap" and the pd library file "pcap.pd_linux" for
> Several programming languages use such naming... the hyphen makes it like a
> namespace in the package-manager, and the complete lack of the "pd-" prefix
> in the context of pd makes it look like you're loading the original "pcap"
> itself into Pd (which, of course, makes a lot more sense if that's exactly
> what your lib does : a plain wrapper and nothing else). I think that this is
> the kind of naming that users of several other programming languages have
> come to expect (Perl, Python, Tcl, Ruby, PHP, etc.)
> | Mathieu Bouchard ------------------------------ Villeray, Montréal, QC
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pd-list