[PD] L2Ork Pd update now available

Hans-Christoph Steiner hans at at.or.at
Fri Dec 17 18:14:33 CET 2010

On Dec 16, 2010, at 4:11 PM, Ivica Ico Bukvic wrote:

> On Wed, 2010-12-15 at 17:15 -0800, Jonathan Wilkes wrote:
>> Hi Ivica,
>>     This may just be leftovers from a previous install:
>> When I run pd by typing in '/usr/local/bin/pd-l2ork' it works fine.
>> When I run it by typing pd-l2ork, I get:
>> sh: /usr/bin/pd-gui: not found
>> And it just waits there until I hit <ctrl-c>.
>> Any hints?
>> -Jonathan
> Actually, it seems that the default installer in packages/linux_make/
> folder fails to produce sane binary when building a tarbz2 rather  
> than a
> deb. First of all it keeps running dpkg-shlibdeps even when running  
> make
> tarbz2 as it has an if statement that changes it to deb (if deb  
> package
> is present) and then it assumes that binary should be built in /usr/ 
> bin
> directory rather than in /usr/local/bin.
> Hans, shouldn't the following code be under the package: part?  
> Otherwise
> it overrides tarbz2 settings if one has dpkg-deb installed  
> regardless of
> what the user has input and results in erroneous build, no?
> # if machine has dpkg-deb, build a Debian package
> ifeq ($(shell test -x /usr/bin/dpkg-deb && echo YES),YES)
> else
>  PACKAGE_TYPE = tarbz2
> endif

I recently committed some fixes to the packages/linux_make/Makefile to  
fix this.  Have you tried the newest version?



You can't steal a gift. Bird gave the world his music, and if you can  
hear it, you can have it. - Dizzy Gillespie

More information about the Pd-list mailing list