[PD] starting [pd~] causes: tcl: /usr/lib/bin/pd.tk: can't open script

Husk 00 husk00 at gmail.com
Mon Mar 7 15:05:04 CET 2011

On Mon, Mar 7, 2011 at 2:04 PM, John Harrison <johnharrisonwsu at gmail.com> wrote:
> When I send [start( to [pd~] I get "tcl: /usr/lib/bin/pd.tk: can't open
> script" in the command window.

Hi John,
first try pddir flag to set the pd path. It could works.
But if it doesn't, as for me, you can try to use pd-vanila (for [pd~])
in conjunction with pd-extended libraries/externals (the extra dir).
After a night of pd Chat and testing (different machines, different
platforms) was the only way to get it working on linux. Seems to
remember pd~ works correctly on MacOS X.
I know it's not elegant but it's worked for me. I'm curious to know if
someone get it working.

> since /usr/lib/bin/pd.tk didn't exist I tried
> ln -s /usr/lib/pd-extended/bin/pd.tk /usr/lib/bin/pd.tk
> still no go. I had also been getting other variations of file not found for
> watchdog and pd-gui but symbolic links appeared to fix those:
> ln -s /usr/lib/pd-extended/bin/pd-watchdog /usr/lib/bin/.
> ln -s /usr/lib/pd-extended/bin/pd-gui /usr/lib/bin/pd-gui
> pd 0.42.5-extended downloaded as a binary from the pd site, running on
> ubuntu Maverick
> workaround?
> --
> John
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management ->
> http://lists.puredata.info/listinfo/pd-list

when Art become pratical
we call it technology.

When Technology become useless
we call it Art


More information about the Pd-list mailing list