[PD] TouchOSC and Pure Data on OS X

Wilfred de Zoete puredata at klankontwerp.nl
Wed Mar 9 11:01:27 CET 2011

Installing the library on OSX was easier than I thought: path and 
startup under preferences.
Now I can create the objects. But... I still cannot open all the patches 
that I downloaded from the TouchOSC-site and Williams patch has the same 
problems. I just get a watch as mouse pointer. I can open and make new 
or other patches while this is going on but nothing happens. When I try 
it again sometimes PD crashes.

I did get a new patch to work. Basically I used the same objects as 
William described in his first reply ( that would be [udpreceive 8000], 
[unpackOSC], [print x] ) but to get a connection going I first had to 
connect from PD to the iPhone with the following comment and object:

[ connect 9000 \

I hope this will help Richie as well.



Op 09-03-11 10:05, Wilfred de Zoete schreef:
> Thanks for the replies. I will comment on some quotes below:
> Op 09-03-11 03:40, William Brent schreef:
>> OSCulator is really fantastic, yes.  In this case though, I think it's
>> easier to keep things streamlined and route everything in Pd.  I
>> didn't think of it until your reply, Richie, but I made this
>> abstraction for touchOSC's "simple" layout.  Just invoke it with a
>> port number [ipad-interface 8000] and you'll get all the parsed data
>> flowing to well-named sends.  For instance, to get the data from fader
>> 4 on page 1 of the simple layout, you can receive from [r
>> ipad-8000-p1-fader4].  Comb through the rest of the patch to see how
>> other sends are named.
> - Thanks. I will install the mrpeach library (I have updated my 
> SVN-folder although I haven't used it in PD yet) and try your patch.
>> On Tue, Mar 8, 2011 at 9:31 PM, Richie Cyngler<glitchpop at gmail.com>  wrote:
>>> My problem with TouchOSC was getting it to see my laptop. I haven't been
>>> able to set up a network with just the laptop and TouchOSC (though I haven't
>>> tried for a while) this is supposed to work though.
>>> As far as using OSC in Pd check out the mrpeach library. It is awesome.
>>> I'm sure it's possible to get the OSC data to come straight into Pd but in
>>> regards to getting those messages all nice and neat and easy I recommend
>>> OSCulator (I have no connection to guy making it, I just like it). It's
>>> third party software. Very easy to use and works very well. It's OSX only.
>>> I've used OSCulator for wiimotes and wacom tablets... I'm not really using
>>> OSC at the moment, so I haven't had a chance to give TouchOSC a good going
>>> over yet, but OSCulator does support TouchOSC.
>>> Hope that helps.
> - Somehow I got the patch working once without any 
> library-installation... I don't know how but now I know that it's not 
> part of the normal extended because when I try to reproduce Richies 
> patch PD prints "...couldn't create".
> I have also downloaded and will buy OSCulator and got it up and 
> running, I got it to control iTunes via Applescript (Apples native 
> Remote app has issues here) and QLab. I also got LiveControl running 
> to control ... Ableton Live.
> My first attempt with TouchOSC and PD got a good connection too as 
> print was working overtime with the xyz-axis. This was via direct 
> connection via UDP from iPhone to PD. The hostname is mycomputer.local 
> and I used outgoing port 8000.
>>> On Wed, Mar 9, 2011 at 12:28 PM, Wilfred de Zoete<puredata at klankontwerp.nl>
>>> wrote:
>>>> I have recently purchased TouchOSC on the iPhone and have succesfully
>>>> controlled Ableton Live with LiveControl and iTunes and other programs with
>>>> OSCulator (AppleScript).
>>>> When I try the PD-examples fromhttp://hexler.net/software/touchosc  I have
>>>> no succes. When I want to open the .pd file with the most recent version of
>>>> PD extended (0.42.5) I get the old watch and nothing happpens. This is also
>>>> the case with older PD's I use.
>>>> I got the 'basic.pd' up and running before I installed one of the other
>>>> programs (LiveControl or OSCulator or TouchOSC Editor) but cannot remember
>>>> which one.
>>>> I know that the .pd files have a prefilled [OSCreceive] (don't remember
>>>> the correct syntax) with port 8000. OSCulator has a default port of 8000 as
>>>> well. So I tried a cold boot and did not start up any other program than PD.
>>>> Even this did not help.
>>>> Could this be the problem?
>>>> Are there more people working with TouchOSC and PD? Can someone help me
>>>> trying to make a new OSCreceive from scratch with the correct syntax?
>>>> System specs: iOS4.2.1 on iPhone 3G - OS X 10.6.6 on late 2008 15" MBP.
>>>> All software is up to date.
>>>> Thanks in advance!
>>>> Greets,
>>>> Wilfred
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management ->  http://lists.puredata.info/listinfo/pd-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20110309/0d9778f1/attachment-0001.htm>

More information about the Pd-list mailing list