[PD] udp broadcasting with netsend: permission denied in Linux

Matteo Sisti Sette matteosistisette at gmail.com
Thu Mar 31 16:50:48 CEST 2011

By the way, if I try to connect to (which is the broadcast 
address for my actual local network) instead of, I get 
the same error in the terminal, but in this case, in the Pd console I 
also see the message "bad host?"

On 03/31/2011 04:46 PM, Matteo Sisti Sette wrote:
> Hi,
> I've used netsend for broadcasting UDP packets to the local network for
> years, connecting to (or any other port >1024) and
> I never had problems under Windows.
> However in Linux it doesn't work, it doesn't connect. If I run Pd from a
> terminal, I see this error in the terminal output: "connecting stream
> socket: Permission denied (13)" (one of the few errors that don't appear
> in the pd console btw).
> I remember mentioning this some time ago and being told that it had been
> fixed, but it seems it isn't.
> Is there a way to circumvent this and be able to broadcast udp packets
> with netsend?
> thanks
> m.

More information about the Pd-list mailing list