[PD] pd-extended 0.43 default settings don't load libdir? + font question

Jacob Lee artdent at gmail.com
Mon Sep 26 05:41:13 CEST 2011

On Sun, Sep 25, 2011 at 11:24 PM, Jonathan Wilkes <jancsika at yahoo.com> wrote:
>>#2 - Pd can't find any fonts other than Courier. This might actually
>>be a tk problem, based on the following tclsh session:
>>% package require Tk
>>% font families
>>{fangsong ti} fixed {clearlyu alternate glyphs} {courier 10 pitch}
>>{open look glyph} {bitstream charter} {song ti} {open look cursor}
>>newspaper {clearlyu ligature} mincho {clearlyu devangari extra}
>>{clearlyu pua} dotum clearlyu clean nil {clearlyu arabic} {clearlyu
>>devanagari} batang {standard symbols l} gothic {clearlyu arabic extra}
>>That list is short and doesn't include e.g. DejaVu Sans Mono, which is
>>installed on my system via the ttf-dejavu package. I've noticed that
>>the standard default.pdextended includes
>>/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType on the search path,
>>and I tried adding /usr/share/fonts/truetype/ttf-dejavu to that list
>>to see if it would help, but no dice. I couldn't figure out from the
>>code how e.g. $sys_searchpath affects Tcl's font search path. Anyone
>>have any ideas what could be going wrong?
> I get fewer fonts recognized under wish8.4 than I do under wish8.5.
> I just force it to use tcl/tk 8.5 and things seem to look ok.

Awesome, that did the trick. I ran update-alternatives to set
/usr/bin/wish to be provided by /usr/bin/wish8.5, and now fonts are
working. Thanks.

> -Jonathan

Jacob Lee
artdent at gmail.com

More information about the Pd-list mailing list