[PD] py/pyext

Thomas Grill gr at grrrr.org
Tue Oct 4 17:06:46 CEST 2011

Hi Benoit,
so you have loaded the external library successfully which is  
indicated by the banner ("py/pyext 0.2.1pre - python script objects"  
etcc) in the console
and upon instantiation there's no further output than "pyext simple  
ex3 ... couldn't create"?
That's strange, because if there's an error with Python, not being  
able to load a module (script) or having another problem, there would  
be an additional error message from Python (like "ImportError: No  
module named simple").

Am 04.10.2011 um 16:31 schrieb Benoît Pin:

> Hi all,
> I'm trying to use the py/pyext extra on OSX 10.7 with Pd-extended  
> 0.42.5. I managed to instantiate [py] and [pym] objects, but not  
> [pyext …].
> I tried to open the demo patch "attr-1.pd" and the [pyext simple  
> ex3] object is dashed in red, and the console prints "pyext simple  
> ex3 ... couldn't create". I've found on archives that the "scripts"  
> folder needs to be in the pd search path (and it is the case for  
> me). I've also checked this "scripts" folder and it contains a  
> simple.py module within a ex3 class. So, everything should be ok, it  
> seems. Unfortunately, it still doesn't work. I guess that I'm  
> missing some piece of information…
> Any help will be appreciated.
> Benoît Pin.
> _______________________________________________
> Pd-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list